Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: ~TSS~ "Gus"

  1. #11
    Addicted to RC STANG KILLA SS's Avatar
    Join Date
    Aug 2008
    Posts
    2,540
    got the axles back from Clay. WOW:shock:

    had him do full length with a flipped rear axle.
    straight tubes on the rear with no lockouts and no chamfer on the ends.
    link mount hardware is all hidden from the front visable side of the axles. no screw heads or holes. just smooth continuous tube. super scale looking!




    a few unique things I had him do was make the alumimum tubes so that I could run with or without steel beef tubes inside. obviously not needed for strength, but to tune axle weight as I hope to attempt to run no wheel weights for the first time.
    also I had him adapt a SCX panhard mount since they mount atop the axle instead of the gay wraith versions that have a band that goes all the way around the axle tube and simply clamps on.
    you can see the beef tube inside here. Clay nailed these puppies. awesome work!



    got this thing into a roller today. still struggling with WB bias and getting the looks right.


    here you can see the WB bias. I had originally designed the chassis to have the front and rear axles way rearward in the chassis. it was really important to me to have the full grill. and not have to hack it up, narrow it, or remove it completely like most C3s/wraiths. but it looked really terrible. opposite of most rigs WB bias.
    so ive shortened the rear links, and made the front links longer pretty much to there max. still looks a little goofy to me:cry: looks even worse with the body on. WB is about 13.75" right now. ignore the mockup wheels and tires.

    2008 TXRCRCA Super Class State Champ
    2009 Runner Up
    and scaler freak :D

  2. #12
    Addicted to RC STANG KILLA SS's Avatar
    Join Date
    Aug 2008
    Posts
    2,540
    well its been awhile since I updated this thread.
    I wanted to change somethings on the chassis because of my WB bias screw up. but I didn't want to braise it.
    So I bought myself a 95S TIG and have been teaching myself to weld


    one of my pet peives on this project was no swiss cheese tabs. I cant stand them, so unscale. Jesse had some nice full tube shock mounts that I loved. but with the WB bias move they had to go
    cut off the old hoops and welded on new front shock tabs and panhard mount.


    new rear shock mounts and upper link risers


    which allowed me to finally dial in my WB bias and WB length right where I wanted it. sitting at exactly 14". will be lowered later


    got my servo winch made and BEC rx bypass harness made.
    was going to use a HS 645 I had laying around but picked up this Power HD servo for $12 which has a lot more torque. Heyok 6V winch controller inside.


    with the WB moved way forward I had to hack up the front bumper to make some room for servo drag link. mix of tig, mig, and braising here. still have to shorten the ends for tire clearance at full lock.


    which allowed me to finish up the front end steering and all linkages etc. probly gonna redo the panhard with something smaller for more winch spool clearance.


    since the beginning of planning stage of this build, I always knew exactly what wheels I wanted to run. and so the TSS Trail Ready Beadlocks were born


    well all this allowed me to get Gus up and running under his own power for the first time.
    Well I was having trouble with my pinion gear over engauging into the ring gear. i first thought i had a motor/esc issue, and started removing peice by piece to find the problem. finally when i had bare axles in my hand i found the problem.

    if you push in on the pinion gear it would notchy/hard "spin" about 2 teeth, then completely lock up. wont spin, ease up, twist, and push in and it will spin another 2-3 teeth and then lock up again as you press in. does the same thing when on the truck and driveshafts hooked up and powered by motor/trans.

    every single part is brand new.

    if you pull out on the pinion gear and spin it, it spins free and smooth.

    does this with both Stock and HD UD/OD gears.

    so the fix was to order up some shims. two .5mm shims on each axle seems to have fixed it


    lastly ive started base work on the interior.


    lots more to go
    2008 TXRCRCA Super Class State Champ
    2009 Runner Up
    and scaler freak :D

  3. #13
    Administrator sgtsteve's Avatar
    Join Date
    Sep 2008
    Location
    Georgetown, TX
    Posts
    2,214
    Love the profile Gus has


    Team Manager
    - SCALE PERFORMANCE PARTS -




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •